WinReducer.net Project
Would you like to react to this message? Create an account in a few clicks or log in to continue.

WinReducer.net ProjectLog in

FORUM

description[ANSWERED] .NET Framework 3.5 Integrating Problem Empty[ANSWERED] .NET Framework 3.5 Integrating Problem

more_horiz
Hi all,

Im using Ex 1.0.2.0 and W8.1 Core x64 with update. Also i used three different iso and it doesn't matter.

The question is, is it possible to integrate .net framework 3.5 while allowing expert winsxs optimization? Im using a very minimal config.

My Config File

When i try to install this image, im getting error when installation about complete that says "setup files corrupted, contact the vendor etc."

description[ANSWERED] .NET Framework 3.5 Integrating Problem EmptyRe: [ANSWERED] .NET Framework 3.5 Integrating Problem

more_horiz
I got "setup files corrupted, contact vendor" error again. I didn't integrate .net franework while using exper winsxs optimization but still got this error. May be its general problem.

description[ANSWERED] .NET Framework 3.5 Integrating Problem EmptyRe: [ANSWERED] .NET Framework 3.5 Integrating Problem

more_horiz
hi,

when do you get this error? right after "loading" windows to format your hhd ?
or during the installation ?

if it happens while loading your windows iso (before the windo appear where you can format your HHD) it could be "EXPERT - WinSXS Folder Cleanup (boot.wim)"

if it happens after the formating window (during the installation of windows) it could be
"EXPERT - WinSXS Folder Cleanup (install.wim)"

description[ANSWERED] .NET Framework 3.5 Integrating Problem EmptyRe: [ANSWERED] .NET Framework 3.5 Integrating Problem

more_horiz
Its install.wim. Error appears after installation, right after installing updates section.

description[ANSWERED] .NET Framework 3.5 Integrating Problem EmptyRe: [ANSWERED] .NET Framework 3.5 Integrating Problem

more_horiz
Have you integrated any updates?

description[ANSWERED] .NET Framework 3.5 Integrating Problem EmptyRe: [ANSWERED] .NET Framework 3.5 Integrating Problem

more_horiz
brittech wrote:
Have you integrated any updates?

Nope. I didn't integrate anything. In the first i integrated .net framework 3.5, after that i removed it and still got same error.

description[ANSWERED] .NET Framework 3.5 Integrating Problem EmptyRe: [ANSWERED] .NET Framework 3.5 Integrating Problem

more_horiz
Ok, thanks.
How did you integrate .net 3.5?
Just to be clear, have you tried not using WinReducer with the original DVD?

So,
1. Copy original DVD contents to HDD
2. Enable .NET 3.5 using DISM
3. Create new DVD using oscdimg
4. Test installation

If that works then we know the error isn't caused by your source, it is most likely something with WinReducer...

description[ANSWERED] .NET Framework 3.5 Integrating Problem EmptyRe: [ANSWERED] .NET Framework 3.5 Integrating Problem

more_horiz
I tried. I created image with winreducer and tried to enable .net framework 3.5 with dism:

Dism /online /enable-feature /featurename:NetFx3 /All /Source:F:\sources\sxs /LimitAccess

But it says component store corrupted. Then i tried these commands:

Dism /Online /Cleanup-Image /CheckHealth

Dism /Online /Cleanup-Image /ScanHealth

Dism /Online /Cleanup-Image /RestoreHealth

Sometimes its working, sometimes not. I got different results even with same configs.

description[ANSWERED] .NET Framework 3.5 Integrating Problem EmptyRe: [ANSWERED] .NET Framework 3.5 Integrating Problem

more_horiz
Hello,

Don't worry the fix will be deployed next week ... Smile

description[ANSWERED] .NET Framework 3.5 Integrating Problem EmptyRe: [ANSWERED] .NET Framework 3.5 Integrating Problem

more_horiz
You will need to enable .NET 3.5 first, before you do anything with the image (offline).

Here are the commands to do that, but make sure they match your drive labels and directory paths...  (For example, I have a D: drive,  wimoffline folder)
Also, index:1  for me means Professional version.

Code:

dism   /mount-image   /imagefile:D:\Win81x64\sources\install.wim  /index:1   /mountdir:D:\wimoffline
dism   /image:D:\wimoffline   /enable-feature   /featurename:NetFx3   /All   /Source:D:\Win81x64\sources\sxs
dism   /commit-image   /mountdir:D:\wimoffline

description[ANSWERED] .NET Framework 3.5 Integrating Problem EmptyRe: [ANSWERED] .NET Framework 3.5 Integrating Problem

more_horiz
winterstorm2050 wrote:
Hello,

Don't worry the fix will be deployed next week ... Smile

Hi,

I know you will do Smile This .net framework really boring sometimes.

description[ANSWERED] .NET Framework 3.5 Integrating Problem EmptyRe: [ANSWERED] .NET Framework 3.5 Integrating Problem

more_horiz
brittech wrote:
You will need to enable .NET 3.5 first, before you do anything with the image (offline).

Here are the commands to do that, but make sure they match your drive labels and directory paths...  (For example, I have a D: drive,  wimoffline folder)
Also, index:1  for me means Professional version.

Code:

dism   /mount-image   /imagefile:D:\Win81x64\sources\install.wim  /index:1   /mountdir:D:\wimoffline
dism   /image:D:\wimoffline   /enable-feature   /featurename:NetFx3   /All   /Source:D:\Win81x64\sources\sxs
dism   /commit-image   /mountdir:D:\wimoffline


Ok, ill try these commands and share results.. Thanks brittech Smile

description[ANSWERED] .NET Framework 3.5 Integrating Problem EmptyRe: [ANSWERED] .NET Framework 3.5 Integrating Problem

more_horiz
Mesen wrote:
Hi,

I know you will do Smile This .net framework really boring sometimes.

Yes, and this a top priority for EX-81 and EX-100 .. Wink

description[ANSWERED] .NET Framework 3.5 Integrating Problem EmptyRe: [ANSWERED] .NET Framework 3.5 Integrating Problem

more_horiz
Not sure this is solved.
I cannot activated Net 3.5 and do more integration and reduding in the same raw

description[ANSWERED] .NET Framework 3.5 Integrating Problem EmptyRe: [ANSWERED] .NET Framework 3.5 Integrating Problem

more_horiz
Hey,

I've included a Protect preset, named "Protect Windows Features" in "Presets" tab, have you used it ?

description[ANSWERED] .NET Framework 3.5 Integrating Problem EmptyRe: [ANSWERED] .NET Framework 3.5 Integrating Problem

more_horiz
no,
You mean we have to use it and select "net 3.5"
I will have a try

Stay tune

description[ANSWERED] .NET Framework 3.5 Integrating Problem EmptyRe: [ANSWERED] .NET Framework 3.5 Integrating Problem

more_horiz
No, I misunderstood your question, sorry ... Crying or Very sad

So, to correctly answer you ... Wink ... the net35 integration may be disable in 2 circumstances :
- Net35 has been (physically) removed (not disabled)
- Net35 necessary files in your ISO are not available (in "sources\sxs" folder)

description[ANSWERED] .NET Framework 3.5 Integrating Problem EmptyRe: [ANSWERED] .NET Framework 3.5 Integrating Problem

more_horiz
So I think there is a problem
It was OK Under 2.2.1
with

Code:

    <Element Category="Features" Name="Net Framework 3.5" Selected="true" Value="enable" />
    <Element Category="System" Name="Integrate - Net Framework 3.5" Selected="true" Value="F:\AdmMesnage\_Data\Bureau\WinReducer\WinReducerEX81\WORK\INTEGRATE\UPDATES\Framework35\x64" />


I don't fully understand How Framework35/x64 is filled

description[ANSWERED] .NET Framework 3.5 Integrating Problem EmptyRe: [ANSWERED] .NET Framework 3.5 Integrating Problem

more_horiz
Hi, I want to integrate/enable all .net in Windows 8.1 iso.
Please guide me with easiest way, I never used DISM.
I have one ISO with updates and other without updates, I want to test for both. Thanks
privacy_tip Permissions in this forum:
You cannot reply to topics in this forum